[Ncep.list.emc.glopara-support] satang.gdas.2010081500 file

Kate Howard kate.howard at noaa.gov
Wed Jan 18 13:38:27 EST 2012


The angle update step (angu) failed because the new satang file was not
generated in the analysis step (anal). I see that the satang file from the
previous cycle is too small. I have run across this before. You will need
to process the satang file for the 00z cycle and try it again.

Your satang:

v1n3 38 % ll satang.gdas.2010081500
-rwxr-x---    1 wx20cs   g01         1084552 Jan 18 08:37

One from a recent run fo mine:

v1n3 42 % ll /hfip/scrub/wx24kh/para_nhc/prikecntrl/*satang*
-rw-r--r--    1 wx24kh   g01         1141748 Oct 22 10:20

>From George Gayno on this issue:

With the last implementation, the /nwprod/fix/global_satinfo.txt file was
modified to include new satellites and remove old satellites.  The number
and order of the records in the global_satinfo.txt file much match the
records in the satang and biascr files, or as you found out, problems will
occur.  Andrew wrote two small programs that will convert
pre-implementation satang and biascr files for use with the new
global_satinfo.txt file.  Those programs are in
prd11q1r/bias_files (Modify_Biascr.f90 and Modify_Satang_bias.f90).  You
will need to modify variables file_in and file_out to point to the 'pre'
and 'converted' files.  Then do an 'xlf90' to compile.

I have copies of these scripts on Vapor in the following location:


Pull copies to your own space, modify the following lines in each code
before compiling and running (example for satang):


Let me know if this doesn't solve the issue.

Kate Howard
NCEP/EMC Global Branch
GFS POC / Monsoon Desk

On Wed, Jan 18, 2012 at 11:35 AM, Kathryn Sellwood <
kathryn.sellwood at noaa.gov> wrote:

> Sorry,
> Yes I'm on Vapor ... dayfiles are in /ptmp/wx20cs/rotdatprx .
> Still trying to find my way around.
> On Wed, Jan 18, 2012 at 11:24 AM, Kate Howard <kate.howard at noaa.gov>wrote:
>> Kathryn,
>> Can you point me to your dayfile? You're on Vapor?
>> Kate Howard
>> NCEP/EMC Global Branch
>> GFS POC / Monsoon Desk
>> On Wed, Jan 18, 2012 at 11:18 AM, Kathryn Sellwood <
>> kathryn.sellwood at noaa.gov> wrote:
>>> Hello,
>>> I am getting the following error when I run the angu step for a GFS
>>> parallel run.
>>> 48: ***WARNING*** EOF or ERROR reading input satang file
>>>  48:STOP 99
>>>  48:ERROR: 0032-184 MPI was not finalized  in routine unknown, task 48
>>>  42: ***WARNING*** EOF or ERROR reading input satang file
>>>  42:STOP 99
>>> There seems to be some problem with the file with the satellite angles,
>>> does anyone know if this particular date is a problem ?
>>> The command that gets the file seems to have worked.
>>>    /mtb/save/glopara/trunk/para/__bin/ncpx -p
>>>    /ptmp/wx20cs/rotdatprx//__satang.gdas.2010081500
>>>   /stmp/wx20cs/__nodrop2010081506gdasangu
>>>  cp -p
>>> /ptmp/wx20cs/rotdatprx/satang.__gdas.201008150/stmp/wx20cs/__nodrop2010081506gdasangu
>>> Thanks,
>>> Kathryn Sellwood (wx20cs)
>>> _______________________________________________
>>> Ncep.list.emc.glopara-support mailing list
>>> Ncep.list.emc.glopara-support at noaa.gov
>>> https://lstsrv.ncep.noaa.gov/mailman/listinfo/ncep.list.emc.glopara-support
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lstsrv.ncep.noaa.gov/pipermail/ncep.list.emc.glopara-support/attachments/20120118/d8cf4ea0/attachment.html

More information about the Ncep.list.emc.glopara-support mailing list